Symptom
When registering via the Captive Portal, the user providing an e-mail address and phone number that already exists in the system (e.g. through registration that took place earlier), the system reports an error.
Cause
The system did not have protection for double identity search (per e-mail, per phone number).
The error is only when both are entered at the same time (e-mail and telephone). If we provide only one when registering in Captive Portal, there is no error and everything works fine.
Resolution
Recommendations for versions 2.3.17 and older: provide e-mail or phone number, whichever is required. One of them.
The new version 2.3.18 no longer has this limitation in this functionality.